© Сорокин Б.Б. 2016 г.

Функция СУММ

Суммирует все числа в интервале ячеек.

Синтаксис

СУММ(число1;число2; ...)

Число1, число2, ... — от 1 до 30 аргументов, для которых требуется определить итог или сумму.

Внимание!

Учитываются числа, логические значения и текстовые представления чисел, которые непосредственно введены в список аргументов. См. ниже первый и второй примеры.

Если аргумент является массивом или ссылкой, то только числа учитываются в массиве или ссылке. Пустые ячейки, логические значения, тексты и значения ошибок в массиве или ссылке игнорируются. См. ниже третий пример.

Аргументы, которые являются значениями ошибки или текстами, не преобразуемыми в числа, вызывают значения ошибок.

Пример

  A B C
1 Данные Формула Описание (результат)
2 -5 =СУММ(3; 2) Суммирует 3 и 2 (5)
3 15 =СУММ("5"; 15; ИСТИНА) Суммирует 5, 15 и 1, так как текстовые значения преобразуются в числа, а логическое значение ИСТИНА преобразуется в число 1 (21)
4 30 =СУММ(A2:A4) Суммирует три первых числа в приведенном столбце (40)
5 '5 =СУММ(A2:A4; 15) Суммирует три первых числа в приведенном столбце и добавляет 15 (55)
6 ИСТИНА =СУММ(A5;A6; 2) Суммирует значения в двух последних приведенных строках и добавляет 2. Так как нечисловые значения в ссылках не преобразуются, значения в столбце игнорируются (2)