© Сорокин Б.Б. 2016 г.

Функция И

Функция И возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.

Синтаксис

И(логическое_значение1; логическое_значение2; ...)

Логическое_значение1, логическое_значение2, ... — это от 1 до 30 проверяемых условий, которые могут иметь значение либо ИСТИНА, либо ЛОЖЬ.

Внимание!

Аргументы должны быть логическими значениями (такими, как ИСТИНА или ЛОЖЬ), массивами или ссылками, содержащими логические значения. Массив - объект, используемый для получения нескольких значений в результате вычисления одной формулы или для работы с набором аргументов, расположенных в различных ячейках и сгруппированных по строкам или столбцам. Диапазон массива использует общую формулу; константа массива представляет собой группу констант, используемых в качестве аргументов.

Если аргумент, который является ссылкой или массивом, содержит текст или пустые ячейки, то такие значения игнорируются.

Если указанный интервал не содержит логических значений, то И возвращает значение ошибки #ЗНАЧ!.

Пример1

  A B
1 Формула Описание (результат)
2 =И(ИСТИНА; ИСТИНА) Все аргументы — ИСТИНА (ИСТИНА)
3 =И(ИСТИНА; ЛОЖЬ) Один аргумент — ЛОЖЬ (ЛОЖЬ)
4 =И(2+2=4; 2+3=5) Все аргументы расцениваются как ИСТИНА (ИСТИНА)

Пример2

  A B C
1 Данные Формула Описание (результат)
2 50 =И(1<A2; A2<100) Т.к. 50 больше 1 и меньше 100 (ИСТИНА)
3 104 =ЕСЛИ(И(1<A3; A3<100); A3; "Значение вне интервала.") Показывает число из ячейки A3 (если оно больше 1 и меньше 100) или сообщение (Значение вне интервала.)
4   =ЕСЛИ(И(1<A2; A2<100); A2; "Значение вне интервала.") Показывает число из ячейки A2 (если оно больше 1 и меньше 100) или сообщение (Значение вне интервала.)

Еще про Excel.

Разрыв связей

Разрыв связей с источником

Важно! При разрыве связей с источником все формулы, использующие источник, заменяются на их текущее значение. Например, связь =СУММ([Бюджет.xls]Годовой!C10:C25) будет заменена на =45. Эту операцию нельзя отменить, поэтому стоит предварительно сохранить версию файла.

1. В меню Правка выберите команду Связи.

2. Из списка Источник выберите связь, которую требуется разорвать. Для выделения нескольких связанных объектов щелкните каждый из них, удерживая нажатой клавишу CTRL. Чтобы выделить все связи, нажмите CTRL+A.

3. Выполните команду Разорвать.

4. Имя (Имя. Слово или строка знаков, представляющие ячейку, диапазон ячеек, формулу или константу. Используйте описательные имена, такие как «Продукты», для ссылок на диапазоны, значение которых трудно запомнить, такие как Продажи!C20:C30.) связи автоматически не удаляется. Может понадобиться удалить имя.

  Инструкции
  1. В меню Вставка укажите на пункт Имя и выберите команду Присвоить.
  2. В списке Имя выберите имя, которое требуется изменить.
  3. Выполните одно из следующих действий.

  Измените это имя
  1. Введите новое имя для использования в ссылках и нажмите кнопку Добавить.
  2. Выберите имеющееся имя и нажмите кнопку Удалить.

  Измените ссылку, формулу или константу по имени
  Измените ссылку в поле Формула.

  Удалите это имя
  Нажмите кнопку Удалить.

5. Если используется внешний диапазон данных (Диапазон внешних данных. Диапазон данных, входящих на лист, но расположенных вне Microsoft Excel, например база данных или текстовый файл. В Microsoft Excel эти данные можно форматировать и использовать в вычислениях, как и любые другие данные.), параметр запроса может также использовать данные из другой книги. Может понадобиться проверка и удаление этих типов связей.

Управление выдачей запроса на обновление связей

Не задавать вопрос и обновлять связи

Этот режим задается только для текущего пользователя и влияет на все открываемые книги. На работу других пользователей данной книги он не влияет.

1. В меню Сервис выберите команду Параметры, а затем откройте вкладку Правка.

2. Снимите флажок Запрашивать об обновлении автоматических связей. Если этот флажок снят, связи будут обновляться автоматически, без выдачи запроса.

Пользователь указывает, нужно ли задавать вопрос

Внимание!  Этот режим влияет на всех пользователей этой книги. Если отключить обновление связей и выдачу запроса, пользователи этой книги не будут знать, что данные устарели.

1. В меню Правка выберите команду Связи.

2. Нажмите кнопку Запрос на обновление связей.

3. Выберите требуемый режим.

Примечание. При наличии разорванных связей сообщения об этом будут выдаваться в любом режиме.

Замена одной формулы на возвращаемое значение

Внимание!   Microsoft Excel удаляет формулу при замене на возвращаемое значение. Для отмены случайной замены формулы ее значением немедленно после ввода или вставки значения нажмите кнопку Отменить.

1. Выделите ячейку с формулой. Если формула является формулой массива (Формула массива. Формула, выполняющая несколько вычислений над одним или несколькими наборами значений, а затем возвращающая один или несколько результатов. Формулы массива заключены в фигурные скобки { } и вводятся нажатием клавиш CTRL+SHIFT+ENTER.), выделите группу ячеек, содержащих эту формулу.

  Инструкции
  1. Укажите любую ячейку массива (Массив. Объект, используемый для получения нескольких значений в результате вычисления одной формулы или для работы с набором аргументов, расположенных в различных ячейках и сгруппированных по строкам или столбцам. Диапазон массива использует общую формулу; константа массива представляет собой группу констант, используемых в качестве аргументов.).
  2. В меню Правка, выберите команду Перейти.
  3. Нажмите кнопку Выделить.
  4. Установите флажок Текущий массив.

2. Нажмите кнопку Копировать

3. Нажмите кнопку Вставить на панели инструментов (Панель инструментов. Панель с кнопками и параметрами, которые используются для выполнения команд. Для отображения панелей инструментов используется диалоговое окно Настройка (выберите в меню Вид команду Панели инструментов, а затем — команду Настройка). Для просмотра дополнительных кнопок нажмите кнопку Другие кнопки в конце панели инструментов.) Стандартная.

4. Нажмите на стрелку рядом с командой Параметры вставки, а затем выберите команду Значения.