© Сорокин Б.Б. 2016 г.

Функци ИСТИНА и ЛОЖЬ

Функция ИСТИНА возвращает логическое значение ИСТИНА.

Синтаксис

ИСТИНА( )

Внимание!

Можно непосредственно ввести значение ИСТИНА в ячейки и формулы без использования этой функции. Функция ИСТИНА предназначена для совместимости с другими системами электронных таблиц.

Функция ЛОЖЬ возвращает логическое значение ЛОЖЬ.

Синтаксис

ЛОЖЬ( )

Внимание!

Можно непосредственно ввести слово ЛОЖЬ в рабочий лист или в формулу, и Microsoft Excel будет интерпретировать его как логическое значение ЛОЖЬ.

Еще про Excel.

Функции

Функции — заранее определенные формулы, которые выполняют вычисления по заданным величинам, называемым аргументами, и в указанном порядке. Эти функции позволяют выполнять как простые, так и сложные вычисления. Например, функция ОКРУГЛ округляет число в ячейке A10.

=ОКРУГЛ(A10;2)

Структура функции

Структура. Структура функции начинается со знака равенства (=), за ним следует имя функции, открывающая скобка, список аргументов, разделенных запятыми, закрывающая скобка.

Имя функции. Для появления списка доступных функций щелкните ячейку и нажмите клавиши SHIFT+F3.

Аргументы. Существуют различные типы аргументов: число, текст, логическое значение (ИСТИНА и ЛОЖЬ), массивы (Массив. Объект, используемый для получения нескольких значений в результате вычисления одной формулы или для работы с набором аргументов, расположенных в различных ячейках и сгруппированных по строкам или столбцам. Диапазон массива использует общую формулу; константа массива представляет собой группу констант, используемых в качестве аргументов.), значение ошибки (например #Н/Д), или ссылки на ячейку (Ссылка на ячейку. Набор координат, по которым расположена ячейка на листе. Например, ссылка на ячейку, находящуюся на пересечении столбца B и строки 3 выглядит как B3.). В качестве аргументов используются константы (Константа. Постоянное (не вычисляемое) значение. Например, число 210 и текст «Квартальная премия» являются константами. Формула и результат вычисления формулы константами не являются.), формулы, или функции. В каждом конкретном случае необходимо использовать соответствующий тип аргумента.

Всплывающая подсказка аргумента. Всплывающая подсказка с синтаксисом и аргументами появляется после ввода функции. Например, всплывающая подсказка появится после ввода =ОКРУГЛ(. Всплывающие подсказки появляются только для встроенных функций.

Ввод формул.   Диалоговое окно Мастер функций облегчает ввод функций при создании формул, содержащих функции. При вводе функции в формулу диалоговое окно Мастер функций отображает имя функции, все ее аргументы, описание функции и каждого аргумента, текущий результат функции и всей формулы.

Вложенные функции.

В некоторых случаях может потребоваться использование функции как одного из аргументов другой функции. Например, в следующей формуле функция СРЗНАЧ вложена в функцию ЕСЛИ для сравнения среднего значения нескольких значений с числом 50. Аргумент - значения, используемые функцией для выполнения операций или вычислений. Тип аргумента, используемого функцией, зависит от конкретной функции. Обычно аргументы, используемые функциями, являются числами, текстом, ссылками на ячейки и именами.

Допустимые типы вычисляемых значений.   Вложенная функция, используемая в качестве аргумента, должна вычислять соответствующий этому аргументу тип данных. Например, если аргумент должен быть логическим, то есть иметь значение либо ИСТИНА, либо ЛОЖЬ, то вложенная функция в результате вычислений тоже должна давать логическое значение либо ИСТИНА, либо ЛОЖЬ. Иначе появится сообщение об ошибке «#ЗНАЧ!».

Ограничение количества уровней вложения функций.   В формулах можно использовать до семи уровней вложения функций. Когда функция Б является аргументом функции А, функция Б находится на втором уровне вложенности и так далее.